Ağu 06

Android : You need to use a Theme.AppCompat theme (or descendant) with this activity

Merhaba arkadaşlar bu sabah androidde karşılaştığım bir hata ve çok basit çözümünden bahsedeceğim. Uygulamaya yukarıdaki menu’ye bir buton koymak istedim. Butonu eklediğimde ve manifest’te gerekli düzenlemeyi yaptığımda

‘You need to use a Theme.AppCompat theme (or descendant) with this activity’

hatası aldım.

Manifest

<activity
    android:name=".Activity"
    android:label="@string/app_name"
    android:theme="@android:style/Theme.Holo.Light">
    <intent-filter>
        <action android:name="android.intent.action.MAIN" />
        <category android:name="android.intent.category.LAUNCHER" />
    </intent-filter>
</activity>

menu_main.xml

<menu xmlns:android="http://schemas.android.com/apk/res/android"
    xmlns:tools="http://schemas.android.com/tools" tools:context=".Activity">
    <item
        android:id="@+id/action_location"
        android:icon="@drawable/radar4040"
        android:showAsAction="always"
        />
</menu>

Hatanın çözümü ise gayet basit. Android studio’da yeni bir proje açtığınızda Activity ActionBarActivity’yi extends etmektedir. Siz bunu Activity şeklinde düzeltirseniz problem ortadan kalkacaktır. İyi çalışmalar.

Bir Cevap Yazın